Jump to content
Estrax

Lenovo Y580

Recommended Posts

Konfiguracja:

 

1. Lenovo IdeaPad Y580

2. CPU: i7 3630QM

3. Chipset: HM76

4. Kontroler napędów: brak

5. GPU: HD4000 + GTX660M, matryca 15.6" z rozdzielczością 1920x1080

6. Dźwięk: ALC269

7. LAN: Atheros AR8161/8165 PCI-E Gigabit Ethernet Controller (10/100/1000MBit)

8. WiFi: Intel Centrino Wireless-N 2200 (bgn) -> zmieniony na Atherosa AR9280

9. Dysk: SATA III, GUID

10. klawiatura i touchpad PS/2, mysz na USB

 

Działa:

- LAN (ALXEthernet)

- USB 3.0 (GenericUSBXHCI)

- Bluetooth (OOB)

- matryca 1920x1080 (OOB)

- HD4000 (DSDT patch, dodanie id karty) - przy 8 GB RAMu wykrywa 384 MB VRAM, przy 16 GB RAMu wykrywa 512 MB VRAM; potrzebny jeszcze tylko patch

- bateria (VoodooBattery)

- wifi (OOB) - pokładowy Intel został zmieniony na AR9280, który działa znakomicie

- kamera (OOB)

- audio (VoodooHDA)

- PM (w tym stany turbo) i AGPM

- sleep

- zmiana jasności podświetlenia matrycy (fix w DSDT)

 

Nie działa i nie zadziała:

- GTX660M - karta wyłączona w biosie

- wifi od Intela - wymieniona na Atherosa AR9280 działającego OOB

 

Aktualnie zainstalowany OSX 10.8.4 na dysku, oraz clover. Korzystam z SMBiosu dla MBP10,1.

 

Po wymianie WiFi sprzęt jest 'fully working' ;-)

Share this post


Link to post
Share on other sites

Na HD4000 zastosuj stringa:

7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000003006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31

 

Na USB 3.0 zastosuj GenericUSBXHCI:

http://www.insanelymac.com/forum/topic/286860-genericusbxhci-usb-30-driver-for-os-x-with-source/

 

Audio jest bardzo łatwe do odpalenia, jest wiele legacyHDA. Możesz też zastosować VoodooHDA 2.8.4:

http://www.projectosx.com/forum/index.php?showtopic=355

Share this post


Link to post
Share on other sites

Ten EFI String popchnął sprawę do przodu - GPU jest wykrywana, lecz kompletnie zniknął kursor - mysz działa, jednak kursor nie jest widoczny, przez co nawigacja jest utrudniona.

 

USB odpalone. Na tą chwilę brak mi tylko i wyłącznie dźwięku + widocznego kursora ;)

Share this post


Link to post
Share on other sites

Update:

 

BIOS/UEFI mam teraz w wersji 2.07 (odblokowany, bez whitelisty) i w porównaniu do wersji 2.06 (też unlocked i bez whitelisty) jest rewelacja, od razu można zauważyć większą ilość widocznych parametrów. Pojawiła się też możliwość edycji ustawień grafiki.

 

Działa:

- LAN (ALXEthernet)

- USB 3.0 (GenericUSBXHCI)

- Bluetooth (OOB)

- matryca (OOB) - możliwe do wyboru rozdzielczości są wykrywane okej, ich zmiana przebiega bez problemu

- HD4000 - jest wykrywana, nie mam już problemu z znikającym kursorem - czyli spory krok do przodu

- bateria (VoodooBattery)

- wifi (OOB) - pokładowy Intel został zmieniony na AR9280, który działa znakomicie

- kamera (OOB)

 

Nie do końca:

- matryca - nie mam możliwości zmiany podświetlenia (a może to kwestia iGPU?)

- HD4000 - aktualnie brak AGPM (w trakcie roboty) + przy 8 GB RAMu wykrywa tylko 384 MB VRAM, nie powinno być przypadkiem 512 MB? Odtwarzacz DVD działa, szachy też... ale w przypadku szachów jest koszmar - brak płynności, straszna pikseloza przy przesuwaniu pionków.

- PM - mam gotowe spatchowane SSDT w acpi/patched (w Cloverze), ale nie działa mi sleep. Podejrzewam, że nie do końca odpalony jest PM. Czyżby pozostała sprawa edycji DSDT?

 

Nie działa:

- GTX660M - i nie zadziała

- audio - czeka w kolejce, po poprawnym odpaleniu iGPU się za to zabiorę

- sleep - laptop się od razu restartuje po wybraniu opcji uśpienia

 

Powoli i do przodu :-)

Share this post


Link to post
Share on other sites

Przeskocz na najnowszego Clovera, poprawia sprawę sleepu z użyciem CsmVideoDxe - brak restartów po wybudzeniu - nie wiem czy masz natywną rozdziałkę w GUI i czy używasz CsmVideoDxe...

 

Co do podświetlenia - często pomaga wywalenie efi strungów i popchnięcie grafiki przez DSDT, wtedy działa regulacja podświetlania.

Share this post


Link to post
Share on other sites

Update!

Działa wszystko. Sprzęt po zakupie wymaga jedynie wymiany WiFi i wgrania BIOSu/UEFI bez whitelisty. Wykonane zostało trochę poprawek w DSDT i mogę śmiało powiedzieć, że sprzęt jest w pełni działający. Nie liczę oczywiście takich rzeczy jak niemożliwe do odpalenia wifi od Intela, czy GTX660M. No i czytnik kart, którym się nawet nie zajmowałem, gdyż nie jest mi potrzebny (w wolnej chwili zerknę na niego, może się akurat uda odpalić).

 

 

Działa:

- LAN

- USB 3.0

- Bluetooth

- matryca 1920x1080

- HD4000

- zmiana jasności podświetlenia matrycy

- bateria

- wifi (Atheros AR9280)

- kamera

- audio

- PM (łącznie z turbo) i AGPM

- sleep

 

Nie działa i nie zadziała:

- GTX660M - karta wyłączona w biosie

- wifi od Intela - wymieniona na Atherosa AR9280

 

Chyba nie działa (nie sprawdzane, po prostu nie było mi to dotychczas potrzebne):

- czytnik kart

 

Aktualnie zainstalowany OSX 10.8.4 na dysku, oraz clover. Korzystam z SMBiosu dla MBP10,1.

Share this post


Link to post
Share on other sites
Na HD4000 zastosuj stringa:

7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000003006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31

 

 

Gdzie dokladnie i w jakim miejscu to wkleic?

Share this post


Link to post
Share on other sites

EFI String jest do wklejenia w Cloverze.

Jeśli dobrze pamiętam to w wersjach r2xxx:

Devices -> Inject ustawiasz na

Devices -> Properties - tutaj wklejasz ten EFI String ;-)

 

W starszych wersjach Clovera (przed 2xxx):

PCI -> StringInjector ustawiasz na

PCI -> DeviceProperties - tutaj wklejasz EFI String.

Share this post


Link to post
Share on other sites

Mógłbyś mi powiedzieć z którego poradnika korzystać do instalacji mac os x na y580?

Czy konieczne jest pobranie instalki z app store czy można to obejść?

Który bootloader będzie najlepszy?

Czy można to zrobić przez USB czy trzeba wypalać płytę?

Czy zmiany jakie wprowadzasz dotyczą tylko bootloadera czy konieczna jest edycja samego obrazu z OS X tez?

Share this post


Link to post
Share on other sites

Obraz systemu - oczywiście retail z AppStore, bootloader: Clover. 10.8 można przygotować spokojnie pod Windowsem, a mając poprawnie skonfigurowanego Clovera update do 10.9 to formalność. Wszystkie potrzebne materiały i poradniki znajdziesz tu, na forum, w odpowiednich działach. Do ogarnięcia całej instalacji wystarczy Ci klucz USB 8 GB. Obrazu systemu nie edytowałem, bo po co? :)

Share this post


Link to post
Share on other sites

Obraz systemu - oczywiście retail z AppStore, bootloader: Clover. 10.8 można przygotować spokojnie pod Windowsem, a mając poprawnie skonfigurowanego Clovera update do 10.9 to formalność. Wszystkie potrzebne materiały i poradniki znajdziesz tu, na forum, w odpowiednich działach. Do ogarnięcia całej instalacji wystarczy Ci klucz USB 8 GB. Obrazu systemu nie edytowałem, bo po co? :)

 

Dzięki za odpowiedź. Udało mi się zainstalować 10.9.4 na tym Lenovo Y580.

Jednak średnio jeszcze siedzę w temacie i tak po prostu robiłem to co w poradniku znalezionym gdzieś w sieci trochę na pałę.

 

Mam parę problemów ze sprzętem, ale generalnie system działa.

Czy żeby odpalić rzeczy które mi nie działają wystarczy skopiować odpowiedniego kexta z netu do extensions?

Bo np:

 

1. nie działa mi dźwięk w ogóle - podobno łatwa sprawa, coś tam ktoś wspominał o Cloverze - ale nie wiem jak się za to zabrać?

 

2. Nie działa mi kamera, podczas instalacji jak odpaliłem w SafeMode to działała. Nie wiem co jej się stało. Czy wystarczy jakiś kext skopiować? 

 

3. Touchpad scrolluje mi w odwrotnym kierunku, nie widziałem żadnej opcji w syspref/trackpad do zmiany tego, a jest to uciążliwe

Poza tym ogólnie jakoś w Win7 lepiej działa podczas tapów się nie przesówa jak tu, no ale to mógłbym olać najważniejszy ten scrolling.

 

4. Czy da się jakoś zmienić w klawiaturze, żeby alt to był alt, a nie te Mackowe guziki? Teraz pisząc polskie litery muszę wciskać te windowsowe guziki zamiast alta - ciężko się przyzwyczaić.

 

Pozdrawiam.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.