Jump to content
Sign in to follow this  
Ravven

Compal FL90 + Clover 2236 + Official 10.9

Recommended Posts

Witam, szanowne grono forumowiczów. :)

 

Szukam pomocy przy instalacji Mavericksa 10.9 za pomocą Clovera na Compalu FL90, którego dostałem w spadku jako niedziałającego (padła karta graficzna - miała wadliwy chipset nVidia z 2007 r. Wreszcie sobie z nią poradziłem, ale to temat na inną dyskusję :P ).

 

Specyfikacja

 

Compal FL90

Procesor - Core 2 Duo T7100 - 1.8 Ghz

Chipset - ICH8M (tak mi się wydaje)

Grafika - GeForce 8600M GT 256 MB

WLAN - Broadcom 802.11g Network Adapter - BCM94311MCG

LAN - Broadcom NetLink Gigabit Ethernet - BCM5787

Audio - Realtek ALC268

(jest jeszcze trochę sprzętu, ale nie powinien być ważny)

 

Co zrobiłem:

 

Laptop

Na Windzie posprawdzałem sobie wszystkie komponenty i zdaje się być całkiem hackintoshowalnym sprzętem. Ustaliłem też, że najbliższym jego odpowiednikiem będzie seria MacBookPro3,1 - co szczęśliwie pozwala na nim zainstalować 10.9. Wydobyłem też DSDT i wprowadziłem podstawowe poprawki - z resztą pobawię się jak już odpalę Mava.

Dodatkowo wgrałem Bios w wersji 1.18 (jest tu Phoenix).

 

Mavericks

Na hacku ze stopki zassałem z App Store Mavericksa i za pomocą createinstallmedia przygotowałem sobie pena. Na wszelki wypadek przygotowałem też drugi pen z metodą jeszcze z czasów Liona (czyli odtworzenie BaseSystem i skopiowanie Packages + mach_kernel).

 

Clover

Z sourceforge pobrałem installer wersji 2236 i przygotowałem pena. Z paczki wybrałem instalację bootloadera boot0af w sektorze MBR, CloverEfi w wersji 64 bitów z opcją BiosBlockIO (inaczej nie chce w ogóle wystartować), motyw graficzny i oba 64 bitowe drivery dla mouse. Dodatkowo wrzuciłem DSDT do katalogu ACPI/patched, FakeSMC do katalogu Kexts/10.9 i przygotowałem podstawowy config Clovera:

 


ACPI

DSDT

Name
DSDT.aml


Boot

Arguments
-v
Legacy
PBR
Log

Timeout
5

GUI

Language
en:0
Scan

Theme
bootcamp

RtVariables

LogEveryBoot
10
LogLineCount
3000

SMBIOS

BiosReleaseDate
03/05/08
BiosVendor
Apple Computer, Inc.
BiosVersion
MBP31.88Z.0070.B07.0803051658
Board-ID
Mac-F4238BC8
BoardManufacturer
Apple Computer, Inc.
BoardType
10
ChassisAssetTag
MacBook-Aluminum
ChassisManufacturer
Apple Computer, Inc.
ChassisType
8
Family
MacBook Pro
Manufacturer
Apple Computer, Inc.
Mobile

ProductName
MacBookPro3,1
SerialNumber
FC833W7UX91
Trust

Version
1.0


 

Problem:

W zasadzie problem jest prosty - po uruchomieniu Clovera i wybraniu instalki Mavericksa (też z inject kexts i no cache) system dochodzi do linii Root Device UUID is *** i następuje reboot - w przypadku instalki z createinstallmedia, a w przypadku instalki z basesystem do sekcji gdzie wczytuje kexty kropkami ......... i dochodzi do momentu +++++++++++++++ i też reboot.

 

Walczę już z tym któryś dzień. Czy macie jakieś pomysły?

Share this post


Link to post
Share on other sites

Dzięki za szybką odpowiedź, 314TeR. :-)

 

Niestety dodatnie do pliku configu w sekcji Graphics / Inject / NVidia - True nie pomogło, a i tak Clover ustawiał to automatycznie podczas uruchamiania.

Dodałem też DropOEM i Generate / CStates i PStates w sekcji ACPI / SSDT. Także bez zmian.

 

Zastanawiałem się czy problem dotyczy tylko Clovera więc przygotowałem też pena z instalką 10.9 i chameleonem, rezultat był jednak tak sam.

 

Jest ciekaw z czym jest to w ogóle związane i dlaczego tak się dzieje.

 

[ Dodano: 2013-10-29, 21:16 ]

Aktualizacja - 29.10.2013

 

W zasadzie dość dziwnie, bo bez zmiany kextów i DSDT ruszyła mi instalka SL i aktualnie mam już chodzące 10.6.8. Z tym, że... na Chameleonie. Grafikę dodatkowo ruszyłem GraphicsEnabler=Yes i przez PCI Configuration przeszedłem używając npci=0x2000.

Clover co prawda instalację SLa rusza, ale po dojściu do ekranu z wyborem języka instalacji wszystko staje (mogę jednak ruszać myszką; dodatkowo jest szary obraz). Myślałem, że może jest wadliwy Inject nVidii, ale po wyłączeniu tej opcji nadal było to samo.

 

Zacząłem więc szukać innej przyczyny i coś znalazłem.

 

Zasadniczo przy bootowaniu z Chameleona i Clovera zauważyłem jedną znaczącą różnicę. W trybie Verbose używając Clovera nie mam żadnych informacji odnośnie działania FakeSMC - na Chameleonie jest.

Nasuwa mi to podejrzenie o brak albo kexta w odpowiednim katalogu, albo niedziałającego Injectera. Dla pewności wrzuciłem FakeSMC do każdego z katalogów, ale nadal brak jest info o działaniu FakeSMC podczas widoku w trybie Verbose.

 

Czy wiecie coś na temat błędnie działającego skryptu Inject pod Cloverem 2236?

Share this post


Link to post
Share on other sites

Witam, mam pytanie odnośnie Compala. Walczę z nim jakiś czas i nic poza Snow Leopardem i Lionem nie chce mi się uruchomić, mam na myśli instalator od Mountain Liona wzwyż. Chciałbym na nim chociaż Mavericksa odpalić. W Cloverze las krzyży i reboot, w chameleonie zaraz po linijce ACPI Patching. Wszystkie flagi kernela już próbowałem, Injecty, nv_disable, GraphicsEnablery, nic nie pomaga. W sieci też ciężko coś znaleźć na temat tego komputera i czegoś powyżej snow leo... appka na której mi zależy wymaga minimum Mavericksa, jest na niego jakiś sposób ? Z gory dzięki za pomoc.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.