Jump to content
Sign in to follow this  
mati5656

Uniwersalne HDMI Audio dla nvidii ati

Recommended Posts

Witam jestem kompletnie zielony w tym jak naprawić dzwięk przez hdmi na hacku a bardzo jest mi to potrzebne, byłbym bardzo wdzięczny gdyby ktoś mógł mi to wytłumaczyć krok po kroku dla moje karty GTS 450.

Share this post


Link to post
Share on other sites

Masz Mavericksa tak jak ja, mnie pomógł ten kext:

https://www.dropbox.com/s/svh7mxzvoz04kw3/HDMIAudio-1.0.dmg

Uprzedzam pytania/uwagi - nie jest wyciągnięty z Multishita czy innych badziewi. Instalowałem na 10.9.2, po aktualce do bety 10.9.3 następnie finalnej 10.9.3 cały czas działa idealnie.
Znalezione tutaj:

http://forums.macrumors.com/showthread.php?t=1499797

Dla potwierdzenia (jako nazwa dźwiękówki model mojego monitora, niżej karta na USB):

 

https://www.dropbox.com/s/4ffp9m6a0xpcqi9/Zrzut%20ekranu%202014-05-28%2021.45.53.png

Share this post


Link to post
Share on other sites

Akurat to rozwiązanie jest fajne bo czyta ono bodaj z tabel ACPI ścieżki i zastępuje ręczne wstrzykiwanie do DSDT/SSDT. Jest to o tyle fajniejsze rozwiązanie, że jest uniwersalne i nie ma znaczenia w jakim porcie PCIe masz grafikę. Przed chwilą wywaliłem swoje SSDT dla 2x 280X i wpakowałem tego kexta, działa wyśmienicie i nie trzeba się bawić w SSDT po zmianie obsadzenia slotów.

 

PS: nie trzeba pakować skryptu czy nie wiadomo czego. Kexta wystarczy wrzucić do Clovera albo zainstalować kext wizardem.

Share this post


Link to post
Share on other sites

Akurat u mnie skrypt nie działał, więc ręcznie przebudowałem kextcache'a. Jestem w 100% zadowolony. Dźwięk jest dość czysty, nie ma problemów przy aktualizacjach no i działa na NVidiach, jak i na AMD.

Share this post


Link to post
Share on other sites

Jak instalowałeś? Co nie działa dokładnie? Czyściłeś kextcache? HDMI w OS X nie obsługuje regulacji głośności jeśli o to chodzi, dlatego ikonka głośniczka przy zegarku jest poszarzała.

Share this post


Link to post
Share on other sites

O ile dobrze rozumiem chodzi o to, czy na karcie jest układ audio odpowiedzialny za dźwięk na HDMI, czy trzeba połączyć kartę jakimś kablem z dźwiękówką na płycie głównej.

 

Ja mam w stacjonarnym GTS450 w wykonaniu Asusa (DirectCU) i jest tam układ audio. Swoją drogą, ta moja karta ma GPU z nowszej seri 5xx, kompletnie nie wiem czemu.

Share this post


Link to post
Share on other sites

Nie działa mi ów kext na Gryphon Z87 (nvidia gtx780) 10.10 w połączeniu z http://hamac.pl/topic/10139-uniwersalne-legacy-applehda-dla-alc888-1200-892-1150-dla-yosemite-1010-i-starszych-system%C3%B3w/

 

Na 10.9 śmigało aż miło. Probowałem wrzucać do clovera, nie pomaga...

 

wygląda na to, że kext sie uruchamia, ale nie pojawia się urządzenie w ustawieniach audio - w logach coś jest...:

 

01/11/14 19:30:23,000 kernel[0]: HDMIAudio: Found 0x10de0e1a on pci10de,e1a
01/11/14 19:30:23,000 kernel[0]: HDMIAudio: Found 0x10de0e1a on HDAU
 

 

####

Po powrocie do starej metody - http://hamac.pl/topic/7072-legacyhda-alc882-888-889-892-898-1150-1200-on-asus-msi/page-8?do=findComment&comment=95750 - działa z powrotem

Edited by klez84

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.